"Dribble" Owners please post your bugs here

Post all your "Dribble" Bugs here for Simon
User avatar
Steinie
Captain
Posts: 2787
Joined: 21 May 2009, 17:38
Type the number ten into the box: 10
Contact:

"Dribble" Owners please post your bugs here

Post by Steinie » 25 Sep 2009, 16:32

Simon requested a section for us to post our Dribble bugs so that
he can easily find them. We hope that they can be addressed someday.
Thanks

User avatar
DesignDevil
Master Chief Petty Officer
Posts: 500
Joined: 22 May 2009, 08:52
Type the number ten into the box: 0
Location: Neuruppin, Germany, Earth.
Contact:

Re: "Dribble" Owners please post your bugs here

Post by DesignDevil » 25 Sep 2009, 16:54

I don't know if this is a bug or if this was a intention. In my eye's it is a bug. The sphere in the attached image has fur, the cube is behind them. As you can see the sphere himself is transparent. The workaround for that would be to create 2 objects, one with fur and one with the texture but for a furred character which should be animated is this no solution so i post this here as a bug or "to do" for the future.
Attachments
dribble_issue_01.jpg
I still use TrueSpace 6.6
Link: My Youtube Channel
Link: www.DesignDevil.de - Plugins, Tutorials and more about TrueSpace 6.6

User avatar
DesignDevil
Master Chief Petty Officer
Posts: 500
Joined: 22 May 2009, 08:52
Type the number ten into the box: 0
Location: Neuruppin, Germany, Earth.
Contact:

Re: "Dribble" Owners please post your bugs here

Post by DesignDevil » 25 Sep 2009, 17:41

Single Side / Transparency / Fragmentation Issue:

In the attached image you see the problem. To render a plane without the odd fragments i have to switch "single side" rendering on. BUT, than i can't render transparent objekts correctly. Result: BUG
Attachments
dribble_issue_02.jpg
I still use TrueSpace 6.6
Link: My Youtube Channel
Link: www.DesignDevil.de - Plugins, Tutorials and more about TrueSpace 6.6

User avatar
DesignDevil
Master Chief Petty Officer
Posts: 500
Joined: 22 May 2009, 08:52
Type the number ten into the box: 0
Location: Neuruppin, Germany, Earth.
Contact:

Re: "Dribble" Owners please post your bugs here

Post by DesignDevil » 25 Sep 2009, 19:41

No Shadows Issue. This bug is happen if you use LOCAL or INFINITE lights with Mapped Shadows in your scene.
Attachments
dribble_issue_03.jpg
I still use TrueSpace 6.6
Link: My Youtube Channel
Link: www.DesignDevil.de - Plugins, Tutorials and more about TrueSpace 6.6

User avatar
DesignDevil
Master Chief Petty Officer
Posts: 500
Joined: 22 May 2009, 08:52
Type the number ten into the box: 0
Location: Neuruppin, Germany, Earth.
Contact:

Re: "Dribble" Owners please post your bugs here

Post by DesignDevil » 25 Sep 2009, 19:57

HDRI - where is my background issue. In this case i used a HDRI image for the lightning. (for this testscene i added also other lights for the lightworks render engine). As you can see, with dribble + HDRI i lost my background. This happens independed if you use a color, gradient or image as background.

EDIT: Environment texture -> show in background is OFF !!!
Attachments
dribble_issue_04.jpg
I still use TrueSpace 6.6
Link: My Youtube Channel
Link: www.DesignDevil.de - Plugins, Tutorials and more about TrueSpace 6.6

User avatar
nigec
Master Chief Petty Officer
Posts: 561
Joined: 21 May 2009, 18:46

Re: "Dribble" Owners please post your bugs here

Post by nigec » 25 Sep 2009, 23:35

the HDRI..
it depends what view you use, if you use the perspective camera it is just black, but if you use a proper camera, the background shows
Attachments
untitled2.jpg
untitled.jpg

User avatar
DesignDevil
Master Chief Petty Officer
Posts: 500
Joined: 22 May 2009, 08:52
Type the number ten into the box: 0
Location: Neuruppin, Germany, Earth.
Contact:

Re: "Dribble" Owners please post your bugs here

Post by DesignDevil » 26 Sep 2009, 00:04

What the hack...ok, good to know. But i think it is a bug - not a feature - or ;) ?
I still use TrueSpace 6.6
Link: My Youtube Channel
Link: www.DesignDevil.de - Plugins, Tutorials and more about TrueSpace 6.6

clintonman
Captain
Posts: 2902
Joined: 21 May 2009, 21:08
Type the number ten into the box: 0
Location: California
Contact:

Re: "Dribble" Owners please post your bugs here

Post by clintonman » 11 Jun 2010, 17:47

OK, I can build Dribble now. No guarantees, but if you post a bug with a sample scene file I can take a look at it. I'm very new to Dribble and Renderman, so don't be afraid to include too many details.
Clinton Reese

http://clintons3d.com

User avatar
Emmanuel
Master Chief Petty Officer
Posts: 550
Joined: 14 Jun 2009, 06:47

Re: "Dribble" Owners please post your bugs here

Post by Emmanuel » 12 Jun 2010, 08:48

Here is a test with a fresh install of 3Delight9.0 and Dribble, with dribble1.04wip080808.tsx, and Clinton's shaders copied in Dribble's folder.
Dribble renders the scene with no textures, no lights, no bump/hair/shaders.
It only takes into account the color of an object if it is painted with a plain color shader (ex: cube painted in red will render red with Dribble)

I tried both 3Delight 64 and 32 bits versions (my system is running XP Pro 64) and the result is the same.
Note that older versions of Dribble don't render better.

[edit] After I replaced the original shaders with Clinton's, all worked fine !
Attachments
3delight90.jpg
Last edited by Emmanuel on 12 Jun 2010, 13:38, edited 1 time in total.

User avatar
Tiles
Master Chief Petty Officer
Posts: 385
Joined: 27 May 2009, 08:34

Re: "Dribble" Owners please post your bugs here

Post by Tiles » 12 Jun 2010, 09:41

Confirmed , unfortunately. Dribble 9.0 renders no textures. Just greyscale.

This was my first install of Dribble. First i thougth i did something wrong. Thanks Emmanuel, you saved me some work :)

Just curious, where are the Clinton`s shaders located?
Free Gamegraphics, Freeware Games http://reinerstilesets.de

Locked