Stopping Shadows against walls

Post Reply
lrdsatyr8
Petty Officer First Class
Posts: 64
Joined: 24 Mar 2013, 20:19
Type the number ten into the box: 10

Stopping Shadows against walls

Post by lrdsatyr8 » 19 Mar 2019, 15:48

Ok... here's a problem I've been having, and I really don't know how to solve it. I want to take advantage of the global lighting environment... however, whenever I use a Global Environment light when I render if I have a wall against a floor, it casts a shadow on the wall itself. Now I know I can turn off CAST SHADOW on the object that is throwing this shadow on the wall, but it doesn't work if I have something like a roof above it... here's a quick example...

Image

The GE Lights/Mapped Shadow lights throw a weird shadow on the wall from the object below it and only appear down toward where the one object meets another... if I turn off the CAST SHADOW it works but then all the shadows for that object are gone, it totally throws off the look.

Image

Using Infinite Lights only the shadows are much too crisp and too artificial. If anyone has any advice or even some light rigs that could help, please let me know!

User avatar
spacekdet
Captain
Posts: 1621
Joined: 27 May 2009, 15:00
Type the number ten into the box: 10
Location: On the day shift at the Utility Muffin Research Kitchen
Contact:

Re: Stopping Shadows against walls

Post by spacekdet » 20 Mar 2019, 02:57

Right Click GE icon to open options panel.
Have you experimented with those settings?
Are you using an an actual HDRI image for the light? Does it do the same thing using a different environment image?
Tried changing the Environment Type? Samples/ sample angle?
You can smooth out infinite /local light shadows by creating an array of them, each with a small amount of intensity. Mapped shadows can be softer than raytraced and can be set per light. (right click any light icon to see it's options- right click again on envir shadows / toggle shadow to set shadow perimeters)
If you have time to kill IBL light is similar to GE ; scale it up to encompass the scene. Mapped shadows can be really slow w/ IBL

Try to change one parameter at a time, and Area Render is your friend.
One other thought I had... is the metal siding reflective? if you turn off reflection on it's material what happens?

User avatar
Emmanuel
Master Chief Petty Officer
Posts: 515
Joined: 14 Jun 2009, 06:47

Re: Stopping Shadows against walls

Post by Emmanuel » 20 Mar 2019, 07:10

You get these unwanted shadows because the Global Lighting Environment is emitting lights below the ground level.

To fix this, you can simply add a ground (plane) in your scene at the ground level and make is large enough to stop all the lights from below.
Or you can use as HDRI a map that will generate no light (black pixels) below the horizon.

Post Reply