Workspace and Modeler camera not matching

Technical questions, etc..
Post Reply
User avatar
Emmanuel
Master Chief Petty Officer
Posts: 560
Joined: 14 Jun 2009, 06:47

Workspace and Modeler camera not matching

Post by Emmanuel »

I am trying to find a way to make use of Modeler cameras in Workspace.

You may have noticed that if you create a camera in Modeler, and set a scene to match a background picture in a window frame, then move to Workspace, the camera settings are changing.
The render in Modeler does not match with the Workspace's render. That's problematic if you want to mix renders from Workspace and Modeler in Photoshop.

See example below : that's the same scene, same windows size, and Bridge is ON. You can see, on the left window showing the Workspace view, that the cubes are touching the left and right borders of the frame. On the right window showing the Modeler view, there is a gap between the frame and the cubes. I was wondering if there was a ratio I could apply to adjust one camera manually.

Here is my experience :

1. If you create a default camera in Modeler. Its size is X=0.5, Y=1.0, Z=1.25 and want to get the exact same view in Workspace, you must select the camera, then clic the Panel tab to see the camera's options and in the FOV field, enter 0.5225 instead of 0.5.

2. Next, if you change the camera zoom in modeler, setting Z value at =0.5, the workspace and Modeler windows won't match again.
Workspace camera's option will show a FOV setting at 1.250. To match both views, you will have to change the FOV to 1.178

3. One more test. Set camera zoom in modeler to Z=1.00, workspace FOV will show 0.625, but 0.643 will be the right setting.

To summ up :
Z=1.250 in Modeler is FOV=0.5225 in Workspace
Z=0.500 in Modeler is FOV=1.178 in Workspace
Z=1.000 in Modeler is FOV=0.643 in Workspace
There is no exact/logical relationship between these ratios... Crazy isn't it ? :o

Did anyone found a trick to make Worspace camera to match Modeler's one ?
camera matching.jpg

Post Reply