truespace constantly crashing while using paint face. ?? 7.6

Technical questions, etc..
Post Reply
User avatar
horusra
Petty Officer First Class
Posts: 70
Joined: 02 Feb 2010, 13:09
Type the number ten into the box: 0
Location: Appleton, Wisconsin. U.S.A.

truespace constantly crashing while using paint face. ?? 7.6

Post by horusra »

Anyone have this same problem? This applies to TS 7.61 beta 8. I have an inside of a building, and I am trying to place a texture on the floor using the "Paint Face" button. After the texture is on the floor, it crashes as soon as I hit any other icon with the mouse........every time. I used to notice little nasty "scene spoilers" like this once in a while with my registered copy of ts 5.1 sp2.

Sometimes ts used to and still does crash when painting textures that have a great number of u/v repeats, and this also applied to the case above at first. I reduced the repeats, but it didnt help. any ideas? I'm hard pressed to think its either one of my pc's. Any help greatly appreciated.

Rob

User avatar
Draise
Captain
Posts: 3166
Joined: 21 Sep 2009, 19:33
Type the number ten into the box: 0
Location: Bogota, Colombia
Contact:

Re: truespace constantly crashing while using paint face. ?? 7.6

Post by Draise »

I have encountered this. Sometimes freezing the mesh with Clinton's freeze script fixes this (on WS). Another is exporting the object as OBJ, then reimporting it into a new scene to carry on (a crude freeze on MS). Or painting it OUTSIDE the scene, save as TS object, then importing it painted into the scene.

As far as I know, sometimes the stackflow of the software code is not very clean and requires a bit too much ram at a time and goes all chocker block and freezes.

It takes a lot to learn, but Blender has good painting tools for free; and Sculptris does the job also, which has almost no learning curve.

Best of luck! Hope you get the job done.

-Draise

User avatar
Finis
Captain
Posts: 4861
Joined: 21 May 2009, 18:26
Type the number ten into the box: 0
Location: North Venezuela
Contact:

Re: truespace constantly crashing while using paint face. ?? 7.6

Post by Finis »

horusra wrote:copy of ts 5.1 sp2
The old versions without workspace were much more stable.

For model side these things help with paint face:
- Turn the bridge off. This is always good if you don't use workspace.
- Put the object in a scene by itself while painting faces.
- Be sure the normals of the object are pointing in the right direction.
- Set to scanline rendering. Do this even if you have DX render on in the active window.
- Turn "backside" off on face selection.
- Apply a solid simple color to the faces. Use "paint over existing material" later to apply the real texture.
- Painting, moving the mouse over the faces, to apply texture, is often a problem so ...
- Select the faces in point edit mode and then click "paint face". Selecting them with paint mode should be ok. Be patient if there are many faces. It is not clear when the process is finished.
- If there are many faces select smaller groups and apply rather than to all at once.

Other options:
- Use non-TS software to texture.
- Texture the model in an earlier version of TS without workspace.
It was a bright cold day in April, and the clocks were striking thirteen.

User avatar
horusra
Petty Officer First Class
Posts: 70
Joined: 02 Feb 2010, 13:09
Type the number ten into the box: 0
Location: Appleton, Wisconsin. U.S.A.

Re: truespace constantly crashing while using paint face. ?? 7.6

Post by horusra »

Thanks for the replies. I will have to go through the things that u guys listed and see what happens. Probably this weekend when I can dedicate the time to experimenting. Thanks again, I really appreciate it.

Rob

Post Reply