First Cycles Blender render..

User avatar
Finis
Captain
Posts: 4525
Joined: 21 May 2009, 18:26
Type the number ten into the box: 0
Location: America!
Contact:

Re: First Cycles Blender render..

Post by Finis » 02 Apr 2018, 13:42

The denoiser with default settings is low quality or splotchy in some scenes. For high quality renders you have to change its settings to have a weaker effect. Not so strong and smaller radius. Still might not be good enough.

Dark scenes have always been a problem in CG. Low quality, loooooong render time.

Try setting the light bounces to a high number in Render->Light Paths.. Then more light can reach into the very dark parts and fill in the grain. I use the Full Global Illumination preset there for final render but you could set bounces even higher. I also turn off caustics there to make it faster unless I really need it. Lights also have bounce property which is high by default.

Old tricks for dark scene:
- render the scene with brighter light and then darken it in paint shop or compositor. Doesn't look quite right but often good enough.
- increase the exposure for the camera

Another thought. Not 100% sure but I think Cycles has a cut off for very dim light rays. Below a certain brightness the light ray isn't considered anymore since it makes little difference to the image. Set that so it never cuts off and maybe more light will bounce to the grainy areas.

Maybe there is a tutorial for dark scenes with Cycles.
The more competitive you are and the stronger you are the farther you’re gonna get. – Barbara4u2c

User avatar
Prodigy
Site Admin
Posts: 909
Joined: 21 May 2009, 14:46
Type the number ten into the box: 0
Location: Uruguay

Re: First Cycles Blender render..

Post by Prodigy » 02 Apr 2018, 14:14

Good advice Finis thanks! :worship:
๑۩۞۩๑ prodigy ๑۩۞۩๑

User avatar
Finis
Captain
Posts: 4525
Joined: 21 May 2009, 18:26
Type the number ten into the box: 0
Location: America!
Contact:

Re: First Cycles Blender render..

Post by Finis » 02 Apr 2018, 15:29

Thanks Prodigy! But ... Just now I tested these things in a simple scene of a deep box with one sun light. Only indirect light would reach the dark interior of the box. Although some of my suggestions are done using other renderers my tests showed them to have little effect in Cycles.

1024 bounces with 500 minimum took much longer and made some difference but still unacceptable grain and unacceptable denoiser performance. It won't let me set it higher than 1024. Camera exposure made it brighter but no change in grain. Low effect settings for denoiser was still quite blotchy. I found the low brightness ray cut off but it made no difference. I used branched path tracing to set just the diffuse to high bounces and that crashed the program at 200. Brighter light improved it but even really bright still had grain which implies the grain is associated with indirect light.

Time to search for tutorials.

Render speed: This sounds dumb but it is the type of mistake we all make sometimes. Did you set your user preferences and Render panel to use your GPU?
The more competitive you are and the stronger you are the farther you’re gonna get. – Barbara4u2c

User avatar
Finis
Captain
Posts: 4525
Joined: 21 May 2009, 18:26
Type the number ten into the box: 0
Location: America!
Contact:

Re: First Cycles Blender render..

Post by Finis » 02 Apr 2018, 15:42

Ah ha! 33 seconds no deniose.
box.jpg
screen.jpg
More diffuse bounces makes it better. More samples = better but longer render.
The more competitive you are and the stronger you are the farther you’re gonna get. – Barbara4u2c

User avatar
Prodigy
Site Admin
Posts: 909
Joined: 21 May 2009, 14:46
Type the number ten into the box: 0
Location: Uruguay

Re: First Cycles Blender render..

Post by Prodigy » 02 Apr 2018, 16:05

Square samples means 24x24 = 576 samples ;)

Render With your settings
testFinis.jpg
Finis, please add a blue light in a corner.. i think the problem is the blend of 2 lights..
๑۩۞۩๑ prodigy ๑۩۞۩๑

User avatar
Finis
Captain
Posts: 4525
Joined: 21 May 2009, 18:26
Type the number ten into the box: 0
Location: America!
Contact:

Re: First Cycles Blender render..

Post by Finis » 02 Apr 2018, 17:19

I'm out of ammo now. Just some guesses. Maybe Draise has a passes/layers/composite thing to do.

With blue spot light.
box.jpg
With denoiser radius 8 both strengths 0.05 apply only to diffuse indirect.
box-denoised.jpg
Your render with those settings looks like there is just no light reaching some spots. So there is no data there and can't be brightened or anything. Use more max bounces and diffuse bounces and see if it gets better. Maybe a lot more. Try the full global illumination preset.

Hack trick that may help: Set the walls in the dark part to emit a small amount of light. Similar: if they are black change to almost black.

Set your chairs etc. to invisible in render for your graininess tests so it is fast. Be sure there is a wall behind the camera, close the room, so light doesn't get out.

Be sure your lights have 1024 bounces in the light's properties.

I have to go to work now.

Test scene Blender file with denoiser on.
Attachments
test.zip
(70.92 KiB) Downloaded 8 times
The more competitive you are and the stronger you are the farther you’re gonna get. – Barbara4u2c

User avatar
Prodigy
Site Admin
Posts: 909
Joined: 21 May 2009, 14:46
Type the number ten into the box: 0
Location: Uruguay

Re: First Cycles Blender render..

Post by Prodigy » 02 Apr 2018, 19:09

Thanks Finis for your time :bananathumb: keep in touch
๑۩۞۩๑ prodigy ๑۩۞۩๑

User avatar
Finis
Captain
Posts: 4525
Joined: 21 May 2009, 18:26
Type the number ten into the box: 0
Location: America!
Contact:

Re: First Cycles Blender render..

Post by Finis » 08 Apr 2018, 16:00

Did you solve this?

A big factor for render speed in cycles is tile size. Small tiles, 16x16, are good for cpu renders. Larger tiles are good for gpu renders. I find that 256 x 256 is often best for gpu. Try the automatic tile size plugin. It doesn't pick the best one for you but it makes it easy to try different ones and it adjusts them to be the same size.

An idea for the speckles. Try scaling the whole scene to be bigger or smaller. Select everything and scale.
The more competitive you are and the stronger you are the farther you’re gonna get. – Barbara4u2c

User avatar
bitkar
Commander
Posts: 1245
Joined: 16 Mar 2010, 07:14
Type the number ten into the box: 0
Location: Czech Republic
Contact:

Re: First Cycles Blender render..

Post by bitkar » 10 Apr 2018, 14:18

a little workaround, which would be maybe also time consuming for render but... if you render the image bigger and scale it down, the noise should be less visible. But it also sucks i guess :D But it can provide some more quality. If you combine in with denoiser in photoshop like Noiseware plugin...
Michal aka bitkar
tS freak since tS2 (1998) and forever (tS7.61 modeler)

User avatar
Prodigy
Site Admin
Posts: 909
Joined: 21 May 2009, 14:46
Type the number ten into the box: 0
Location: Uruguay

Re: First Cycles Blender render..

Post by Prodigy » 19 Apr 2018, 00:50

Hi guys.. thanks for the advices.. still not getting clean results on my renders..

Finis: Yes i 64x64 for cpu and 256x256 for gpu runs the best for my setup..Thanks!

Here is another scene i'm working with.. again Denoise is not giving me the results i expect.. this render has 500 samples.
rendertest.png
Without denoise looks much better IMO..
rendertest.png
Yeah Bitkar, that is an old trick i used in the past to make sharp renders.. so is not a bad option.. :bananathumb:

I found a nice "workaround" for daylight interiors, and it's using AO (Ambient Occlussion) it lights up the scene and the noise is less visible...
The problem it doesnt work for dark scenes.. :|

Same Samples but AO activated.
rendertest.png
๑۩۞۩๑ prodigy ๑۩۞۩๑

Post Reply