Page 1 of 1

Workspace material picker does not work in a camera view

Posted: 17 Jul 2011, 17:47
by clintonman
When I try to pick a material in workspace while looking through a camera view it doesn't work.

Re: Workspace material picker does not work in a camera view

Posted: 20 Jul 2011, 23:30
by trueBlue
Seems to be working for me, Clinton.
tS761/Vista32 Home
Works better if the item is selected first, in this case I was able to Inspect the cube inside the cube only after it was selected.
I could not see any difference with the different Selection methods either.

Re: Workspace material picker does not work in a camera view

Posted: 21 Jul 2011, 05:45
by clintonman
Not working for me at all. The closest I get is it displays some generic material which has nothing to do with what's applied to the objects. I tried with objects selected, no object selected, main view switched to camera, 3d floating view switched to camera and I tried with a fresh new camera.
tS761Full and Rosetta on Win7 64bit and winxp 32bit

Re: Workspace material picker does not work in a camera view

Posted: 04 Sep 2011, 08:13
by yymoz
clintonman wrote:Not working for me at all. The closest I get is it displays some generic material which has nothing to do with what's applied to the objects. I tried with objects selected, no object selected, main view switched to camera, 3d floating view switched to camera and I tried with a fresh new camera.
tS761Full and Rosetta on Win7 64bit and winxp 32bit
Hi clinton, I have had this problem a few times for a number of different reasons...incomplete mesh, poor conversion of mesh from another program or format etc. It occurs across all versions of truespace. The one cause I have had to deal with the most appears to be 'inverted' faces or normals - it was your symptom of 'only offers the default material' that tipped me to it. If the 'material-picker' can't find a face, it won't find its material. Forgive me if this is so obvious and if you had already discounted the possibility, but then again, it can't hurt to check ;)

If this is the case, merely selecting the 'underside-view' may be enough, moving the camera inside the object will also do it - best practice is to check the faces are all united in the orientation you want them in.

respectfully yymoz
[TrueSpace fan - eager beginner]

Re: Workspace material picker does not work in a camera view

Posted: 04 Sep 2011, 15:26
by clintonman
yymoz wrote:
clintonman wrote:Not working for me at all. The closest I get is it displays some generic material which has nothing to do with what's applied to the objects. I tried with objects selected, no object selected, main view switched to camera, 3d floating view switched to camera and I tried with a fresh new camera.
tS761Full and Rosetta on Win7 64bit and winxp 32bit
Hi clinton, I have had this problem a few times for a number of different reasons...incomplete mesh, poor conversion of mesh from another program or format etc. It occurs across all versions of truespace. The one cause I have had to deal with the most appears to be 'inverted' faces or normals - it was your symptom of 'only offers the default material' that tipped me to it. If the 'material-picker' can't find a face, it won't find its material. Forgive me if this is so obvious and if you had already discounted the possibility, but then again, it can't hurt to check ;)

If this is the case, merely selecting the 'underside-view' may be enough, moving the camera inside the object will also do it - best practice is to check the faces are all united in the orientation you want them in.

respectfully yymoz
[TrueSpace fan - eager beginner]
Nope, that wasn't it. I'm pretty sure I used simple primitives for my tests, but when I was going to test your idea I found something. I had a scene with a boolean object with 3 materials went to camera view and tried the material picker and it didn't work. I created a new cube in the scene and suddenly I can pick materials in the camera view. Also happens if I point edit a mesh, suddenly mat picking works. If I scale something in the scene it starts working. If you start truespace and it's already in camera view then material picking works. So I think something is happening or not happening when switching to camera view.

Re: Workspace material picker does not work in a camera view

Posted: 04 Sep 2011, 15:47
by trueBlue
The only way (sofar) I can NOT get the Inspect Widget to work using Vista32, is when the object is not selected.
Perhaps changing the Priority level would help.
HTH

Re: Workspace material picker does not work in a camera view

Posted: 04 Sep 2011, 17:38
by clintonman
trueBlue wrote:The only way (sofar) I can NOT get the Inspect Widget to work using Vista32, is when the object is not selected.
Perhaps changing the Priority level would help.
HTH
Nope, no effect.

Edit: Bah! Now it's working. I don't know what happened, but I guess I'll just be happy and move on. My best guess is some scripting or node building development must corrupted tS at some point.

Re: Workspace material picker does not work in a camera view

Posted: 04 Sep 2011, 19:46
by v3rd3
Wow.... clinton fixes stuff with force of will alone...... :worship:

Re: Workspace material picker does not work in a camera view

Posted: 05 Sep 2011, 03:45
by trueBlue
clintonman wrote:My best guess is some scripting or node building development must corrupted tS at some point.
For sure! Happens to me all of the time and I Reset the Default Context.

Re: Workspace material picker does not work in a camera view

Posted: 10 Sep 2018, 19:12
by trueBlue
I figured out what is happening here when the Inspect tool does not work when viewing from a Camera.
The Inspect tool is actually inspecting the material of the Camera.
Workaround:
1.) Select an object first before using the Inspect tool.

2.) If you have the Unofficial Update 4 installed, LMB + Drag on the object that you want to Inspect.
The Inspect tool will then start to work.