When texturing models TS moves bitmaps to it's own directory

Game Engines, Projects and more
Post Reply
SL1C3R
Marine
Posts: 2
Joined: 23 May 2009, 06:16

When texturing models TS moves bitmaps to it's own directory

Post by SL1C3R » 13 Jun 2009, 16:03

I started using TS for creating basic models for my game. I create and texture the model in TS and export it as .3DS format. When I load the 3DS into my engine the texture path comes from where TS was installed.

ie: trueSpace76\tS\Rs Main Libraries\Bitmaps - Base\texture.jpg

Is there any way to have TS just reference the path I provide? I have all textures well organized in my own asset directories required by my game.

Jack Edwards
Senior Chief Petty Officer
Posts: 181
Joined: 22 May 2009, 04:28

Re: When texturing models TS moves bitmaps to it's own directory

Post by Jack Edwards » 13 Jun 2009, 17:28

Are you working on Model side or workspace side?

Froo and I plan to start working together on a Workspace side solution for you next week. 8-)
No booleans were used in the mangling of this message... :?

YafaRay for trueSpace Project

(Current version: v0.7.0)

trueSpacePlugins.com

SL1C3R
Marine
Posts: 2
Joined: 23 May 2009, 06:16

Re: When texturing models TS moves bitmaps to it's own directory

Post by SL1C3R » 13 Jun 2009, 21:21

I'm using Model side because it's window has the "TS6 Files" menu that allows me to SaveAs->Object, then I select the file format .3ds

I don't see any options like that on the Workspace side. The only save option I see here is in the upper right window bar, "File" and "Help". "File" has a save option and lists what looks like TrueSpace specific formats.

I already have a .3ds importer in my engine so I was looking for that file format.

At any rate, the real problem (for me) is that it makes a copy of the bitmap I choose and puts it in it's own directory, then references that file path in the model, rather than referencing the original file path.

Jack Edwards
Senior Chief Petty Officer
Posts: 181
Joined: 22 May 2009, 04:28

Re: When texturing models TS moves bitmaps to it's own directory

Post by Jack Edwards » 13 Jun 2009, 22:38

I was being a bit tongue-in-cheek. ;) There isn't any 3DS export from Workspace side, yet. Froo and I are joining forces to get an FBX exporter out to you guys asap. It will include 3DS export.

It's been a while since I used model-side for exporting textures. I usually re-texture the materials in the target platform. Maybe one of the model-side veterans can help you out with this specific problem since I'm sure they have addressed it themselves.
No booleans were used in the mangling of this message... :?

YafaRay for trueSpace Project

(Current version: v0.7.0)

trueSpacePlugins.com

User avatar
Emmanuel
Master Chief Petty Officer
Posts: 550
Joined: 14 Jun 2009, 06:47

Re: When texturing models TS moves bitmaps to it's own directory

Post by Emmanuel » 15 Jun 2009, 18:29

SL1C3R wrote: When I load the 3DS into my engine the texture path comes from where TS was installed.

ie: trueSpace76\tS\Rs Main Libraries\Bitmaps - Base\texture.jpg

Is there any way to have TS just reference the path I provide? I have all textures well organized in my own asset directories required by my game.
That folder is the place where Workspace copies the textures of objects being edited in this environment.

Turn the Bridge OFF and load/export/edit your models within Modeler only... and all will be fine :)

User avatar
nigec
Master Chief Petty Officer
Posts: 561
Joined: 21 May 2009, 18:46

Re: When texturing models TS moves bitmaps to it's own directory

Post by nigec » 15 Jun 2009, 19:57

you just need the textures in the same folder as the exported model
As long as your not using TGA or weird sized images you can pull all the textures to a folder by saving as wrl, then re save your scene as whatever ts format your using I cab't stress how important it is to resave, the scene wont reload if you don't, then save your 3DS model to the folder you saved the wrl and textures to

works for me :)

Post Reply